[Novalug] NUC Me Harder

James Ewing Cottrell III jecottrell3@comcast.net
Wed Dec 7 18:21:12 EST 2016


The other day, I went out and bought an Intel NUC5PPYH from MicroCenter. 
My goal was to have an Infrastructure server that I could leave powered 
up (it's only 6W) all the time. I'll run DHCP, a caching DNS, local NTP, 
and maybe Squid to cache Web Traffic. I'll also use it as a Build 
Server, also running TFTP and a Web Server.

Plus, I can always log onto it and display it thru the TV. I'm using it 
UEFI mode, which I plan to do with any machine I can from now on.

Anyway, I tried a bunch of Distros with Varying Degrees of Success.

+ CentOS 7.2 crashes fairly often. Something to do about Fast TSC not 
being usable as a clocksource. I hear that "clocksource=acpi_pm" works 
on the Linux Command line.

X didn't seem to work, but I built the thing in stages. I'll try all at 
once.

+ CentOS 6.8 oddly enough, works nicely. If I wanted to stay in my 
Comfort Zone, I'd simple use this. Good thing you can boot a different 
OS from different partitions or logical volumes.

+ Ubuntu Xenial worked nicely

+ Fedora 23 and 24 would not do DHCP on the Installation screen.

+ Fedora 27 DID the DHCP in Anaconda, but would NOT do it in the 
Installed System. However, I could attach a specific Address/Mask via 
ifconfig, add a route, and ping the outside world.

+ OK, my DHCP "server" is a Linksys router, but I would expect Linux 
itself to have a better DHCP than Anaconda.

+ I haven't tried the Sound yet, I'll plug in the Headphones soon.

+ I haven't tried the WiFi or the Bluetooth yes.

I'll keep y'all posted.

JIM


More information about the Novalug mailing list